Difference between revisions of "Development/Summer of Code/2018/Picard"

From MusicBrainz Wiki
(Ideas)
(Picard Plugins API v2)
Line 6: Line 6:
 
=== Picard Plugins API v2 ===
 
=== Picard Plugins API v2 ===
  
Proposed Mentors: ''samj1912''/''zas''<br>
+
Proposed Mentors: ''samj1912'' / ''zas''<br>
 
Languages/skills: Python, PyQt5, Flask<br>
 
Languages/skills: Python, PyQt5, Flask<br>
  

Revision as of 11:19, 17 January 2018

MusicBrainz Picard

Ideas

Qt5/Py3 Port

Picard Plugins API v2

Proposed Mentors: samj1912 / zas
Languages/skills: Python, PyQt5, Flask

Picard 2.0 is going to be PyQt5 based, which means all the existing plugins have to be ported to PyQt5/Py3. Since Picard v1 plugins will be incompatible with v2 and vice versa, we need to implement a new v2 end-point for the Picard website. This gives us the opportunity to modify the way our plugin system works. There is a need of providing a uniform GUI api for plugins to allow quick GUI option settings, i18n support and UI uniformity with the rest of the Picard code. Also, additional metadata headers need to be implemented to allow cross-platform compatibility checks.

For more info see: PICARD-977