Difference between revisions of "Development/Supported browsers"

From MusicBrainz Wiki
(New page: The MusicBrainz website officially supports the following browsers: * Apple Safari 5.1+ * Google Chrome 18+ * Internet Explorer 8+ * Mozilla Firefox 11+ * Opera 10+ The website should wo...)
 
Line 1: Line 1:
 
The MusicBrainz website officially supports the following browsers:
 
The MusicBrainz website officially supports the following browsers:
  
* Apple Safari 5.1+
+
* Apple Safari 5.1 or newer
* Google Chrome 18+
+
* Google Chrome 25 or newer
* Internet Explorer 8+
+
* Internet Explorer 8.0 or newer
* Mozilla Firefox 11+
+
* Mozilla Firefox 19 or newer
* Opera 10+
+
* Opera 12.10 or newer
  
 
The website should work with javascript disabled if you're not logged in, or not editing data.  Javascript is required to edit.
 
The website should work with javascript disabled if you're not logged in, or not editing data.  Javascript is required to edit.
  
If you file a bug which only affects an unsupported browser or browser version, the developers may close this as WONTFIX.  A bug which affects any of the supported browsers should be fixed. The current set of supported browsers was made official in the [http://chatlogs.musicbrainz.org/musicbrainz-devel/2012/2012-07/2012-07-09.html#T20-04-01-329789 developer meeting on July 9th, 2012]. This list should be revised once every 6 months.
+
If you file a bug which only affects an unsupported browser or browser version, the developers may close this as WONTFIX.  A bug which affects any of the supported browsers should be fixed. The current set of supported browsers was made official in the [https://chatlogs.musicbrainz.org/musicbrainz-devel/2013/2013-05/2013-05-20.html#T19-55-27-304300 developer meeting on May 20th, 2013]. This list should be revised once every 6 months.  While we don't fully support Android Browser, feel free to report any bugs on 4.0+ so that we know what is broken in it.

Revision as of 20:24, 20 May 2013

The MusicBrainz website officially supports the following browsers:

  • Apple Safari 5.1 or newer
  • Google Chrome 25 or newer
  • Internet Explorer 8.0 or newer
  • Mozilla Firefox 19 or newer
  • Opera 12.10 or newer

The website should work with javascript disabled if you're not logged in, or not editing data. Javascript is required to edit.

If you file a bug which only affects an unsupported browser or browser version, the developers may close this as WONTFIX. A bug which affects any of the supported browsers should be fixed. The current set of supported browsers was made official in the developer meeting on May 20th, 2013. This list should be revised once every 6 months. While we don't fully support Android Browser, feel free to report any bugs on 4.0+ so that we know what is broken in it.